I was working on building a new HTPC today and found that creating a bridge the old way no longer worked.

I initially thought that it was an issue with Network-Manager, but found that Ubuntu have switched to using netplan (I'd never heard of it before!)

So, the quick and dirty way to get it work...

Continue reading...

After upgrading my Ubuntu installation from 17.04 to 17.10, I was unable to start the snapd service with the following error:

-- Unit snapd.service has begun starting up.

Jan 20 17:58:00 hostname snapd[7848]: AppArmor status: apparmor is enabled but some features are missing: dbus, network

J...

Continue reading...

I recently bought an odroid c2 for use as a home server and other various things. However, upon installing Armbian and updating Ubuntu (16.04), I found that the bridge would stop working between reboots. I never got to the bottom of it, but I found this workaround.

If you are doing this on a machi...

Continue reading...

I upgraded from ownCloud 9 to Nextcloud 11 a few weeks ago and ever since, I've been unable to get the mobile app to work for Android. After a few days I began to realise that the app was trying to connect on IPv6, but failing. Removing my AAAA record ensured that the app connected using IPv4, but I...

Continue reading...

After running some updates this weekend to my desktop, I found that upon rebooting, I no longer had a desktop to log back into. After finding out that Compiz was crashing with a segfault and no more info, I had to use the Gnome Fallback mode until I had time to look further into it.

Today, I creat...

Continue reading...